Differences

This shows you the differences between two versions of the page.

Link to this comparison view

Both sides previous revision Previous revision
linguisticsweb:tutorials:linguistics_tutorials:automaticannotation:stanford_core_nlp [2019/02/24 12:26]
sabinebartsch [Stanford Core NLP]
linguisticsweb:tutorials:linguistics_tutorials:automaticannotation:stanford_core_nlp [2019/05/15 11:22]
sabinebartsch [Requirements]
Line 19: Line 19:
 ===== Requirements ===== ===== Requirements =====
  
-The Stanford Core NLP Tools require a running Java installation. As many software programs in corpus and computational linguistics require Java and Java is widely used for development in the field anyway, it is advisable to install a full Java JDK (Java Development Kit) which can be downloaded ​from the [[https://​www.oracle.com/​technetwork/​java/​javase/​downloads/​index.html|Oracle Java JDK site]]. This also includes the widely used JRE (Java Runtime Environment) which is a prerequisite for the execution of many different software programs.+The Stanford Core NLP Tools require a running Java installation. As many software programs in corpus and computational linguistics require Java and Java is widely used for development in the field anyway, it is advisable to install a full Java JDK (Java Development Kit) which can be downloaded ​as the [[linguisticsweb:​tutorials:​linguistics_tutorials:​basics:​environment:java|Open JDK]] from multiple sources. This also includes the widely used JRE (Java Runtime Environment) which is a prerequisite for the execution of many different software programs.
  
 Note that the Stanford CoreNLP Tools standardly require Java 8. However, later versions of Java do work fine if you add the following to your command: Note that the Stanford CoreNLP Tools standardly require Java 8. However, later versions of Java do work fine if you add the following to your command: